E series docking station issues with Linux

Discussion of hardware related issues

Moderator: crosscourt

User avatar
crosscourt
Posts: 2644
Joined: Sun Jan 14, 2018 5:38 pm
Location: Wash DC
Contact:

E series docking station issues with Linux

Post by crosscourt » Sat Aug 11, 2018 4:09 am

Both my E5410/6400 can be used with the e port replicator and I never had any issues with the D series with Linux. Thats not the case with the E series docks. Im using a single monitor I already use with my other systems and when I boot with MX17 it loads, I get to the login screen, then it tries to get to the main screen but suddenly changes to a generic XFCE screen where nothing works. Mouse moves but nothing else can be done except to shutdown.

I decided to try a few live cds to see what would happen and it got even more interesting. Only Neon, Kubuntu and PClinuxOS would boot and allow me to get to the main screen where I could navigate normally with no issues. OpenMandriva,Ubuntu Mate, Lubuntu,Neptune,Mint and MX17 live sessions all yielded the same bad results as above. Ok so I had laptop drives with PCLinuxOS and Neon installed. I tried them with the laptops and unfortunately they didnt work either similar to the above bad results.

Took the laptops out of the dock, hooked up the laptop to my monitor and i went in to check settings and made sure it all looked ok. Put it back in the dock, tried it again and same bad result.

Its been awhile since Ive had dock issues with Linux but admittedly havent tried it in awhile. Its not a big deal as i use my laptops independently most of the time but was hoping to use them in the docks for some things.

Ill be curious this weekend when my friend drops off the Win7 E6400 to see if it works with the dock. Im guessing it probably will, as it looks to be some type of driver issue outwardly. Given Dell supports Ubuntu in office settings, I was expecting more.
Site Moderator

User avatar
tlmiller
Posts: 1250
Joined: Tue Jan 16, 2018 12:29 pm
Location: AZ, USA

Re: E series docking station issues with Linux

Post by tlmiller » Sat Aug 11, 2018 5:15 am

I don't use docks as much as I used to, but it was one of the reasons I originally liked KDE, as it was the only DE that handled docks well. It's been so long since I used most other distro's on a dock, but I DID use Neptune of those you had issues with and I did not have any issues. I was using the E-dock II (the big one with USB 3.0 and serial port).

User avatar
crosscourt
Posts: 2644
Joined: Sun Jan 14, 2018 5:38 pm
Location: Wash DC
Contact:

Re: E series docking station issues with Linux

Post by crosscourt » Sat Aug 11, 2018 5:45 pm

This is the E dock pro3x thats compatible with most e5xxx/6xxx laptops. Unfortunately the hard drives with Neon and PCLinuxOS didnt work(these were originally installed on my USFF systems) with the dock even though the live cd versions did. Neptune 5.4 live cd did not work and froze almost immediately upon login screen. I dont use docks much either but given them limitations of the USFF systems, i was toying with the idea of using docks again but this experience has been a complete turn off.

Would doing a fresh install of the distro, already attached to the dock create a compatible install? D series you could use any hard drive with Linux and it just worked. I know Dell uses these docks with Ubuntu so I was a bit surprised. Really dont want to go thru a full install with a KDE distro only to end up with the same situation.

It is very apparent that KDE is the only DE Ive tried that has any chance of working. LXDE, Mate, and XFCE appear to have major issues.

Ive got a Neptune install on the other USFF so I may give that a try but honestly after two other KDE distros I doubt the result will be any different.
Site Moderator

User avatar
crosscourt
Posts: 2644
Joined: Sun Jan 14, 2018 5:38 pm
Location: Wash DC
Contact:

Re: E series docking station issues with Linux

Post by crosscourt » Sat Aug 11, 2018 6:03 pm

Thanks for the tip tlmiller, as I pulled the hard drive from my USFF with Neptune 5.4 and the dock worked just fine. Im typing on it now and will be updating and see if any issues crop up. If it works out I can use Neptune on the other laptops so I can use the docks. Neptune runs very well on the E6400, good speed.

Ill report back.
Site Moderator

User avatar
crosscourt
Posts: 2644
Joined: Sun Jan 14, 2018 5:38 pm
Location: Wash DC
Contact:

Re: E series docking station issues with Linux

Post by crosscourt » Sat Aug 11, 2018 6:12 pm

Ok, updates made and everything is working fine. I dont understand why Neptune worked and Neon and PCLinuxOS didnt from actual installs.

The good news is Neptune is nice and Ill use it for now till I can find other distros that can work with the dock.
Site Moderator

User avatar
crosscourt
Posts: 2644
Joined: Sun Jan 14, 2018 5:38 pm
Location: Wash DC
Contact:

Re: E series docking station issues with Linux

Post by crosscourt » Sat Aug 11, 2018 7:38 pm

Just installed Neptune on the E5410 connected to the dock and it went fine. Not sure what happened with the first live cd test but its been fine so far.

No issues with the dock, all hardware works and performance is excellent. Neptune is certainly one of the lightest KDE installs Ive used and it runs great on both the E5410 and E6400(using a core 2 duo 2.26ghz).

Why the other KDE distros had issues Im not sure and would prefer to have more options but for now its working.

KDE indeed appears to be the only DE that works, even though it seems to also be distro dependent.
Site Moderator

User avatar
crosscourt
Posts: 2644
Joined: Sun Jan 14, 2018 5:38 pm
Location: Wash DC
Contact:

Re: E series docking station issues with Linux

Post by crosscourt » Sat Aug 11, 2018 8:12 pm

Found another distro that works even though the live cd test didnt. OpenMandriva works fine but interestingly ROSA didnt. OpenMandriva and Neptune both use the recent 4.17.11 kernel which makes me think it might be a reason why it works, dont know honestly.

Will continue to test to see if I can find more distros that will work with the dock.
Site Moderator

User avatar
tlmiller
Posts: 1250
Joined: Tue Jan 16, 2018 12:29 pm
Location: AZ, USA

Re: E series docking station issues with Linux

Post by tlmiller » Sat Aug 11, 2018 8:40 pm

While we both dislike it greatly, I've found the latest Ubuntu (with Gnome3) works fine on my dock as well. I've got a Latitude E5550 at work with Ubuntu 18.04 on it to test reports of issues from devs since 95% of them are using Ubuntu w/ Gnome.

User avatar
crosscourt
Posts: 2644
Joined: Sun Jan 14, 2018 5:38 pm
Location: Wash DC
Contact:

Re: E series docking station issues with Linux

Post by crosscourt » Sat Aug 11, 2018 10:47 pm

Ill never use Gnome 3 but did try Ubuntu Mate with no success. PCLinuxOS though works great and Im typing on it right now. Neither Neon nor kubuntu work even with KDE.
Ubuntu support doesnt surprise me given Dell uses it on the Enterprise/server side. The other issue though is I only have 4gb of ram and Gnome 3 uses a lot of ram.
Site Moderator

User avatar
tlmiller
Posts: 1250
Joined: Tue Jan 16, 2018 12:29 pm
Location: AZ, USA

Re: E series docking station issues with Linux

Post by tlmiller » Sat Aug 11, 2018 10:52 pm

I mean I completely agree. My test machine at work has an SSD (60 GB, but still, SSD) and 16 GB ram and I find it sluggish with Ubuntu.

Post Reply